1
<template>
2
  <div></div>
3
</template>
4

5
<script>
6
// TODO: FIX SPREAD OPERATOR ERROR IN CIRCLECI TO ELIMINATE EXPLICIT IMPORTS AND USE BARRELS
7 1
import { 
8
  Authenticator,
9
  SignIn,
10
  SignUp,
11
  SignOut,
12
  ConfirmSignUp,
13
  ConfirmSignIn,
14
  ForgotPassword,
15
  SetMfa,
16
  Chatbot,
17
  PhotoPicker,
18
  S3Album,
19
  S3Image,
20
  SumerianScene,
21
  RequireNewPassword,
22
  Connect
23
} from './components';
24 1
import AmplifyPlugin from './plugins/AmplifyPlugin';
25 1
import AmplifyEventBus from './events/AmplifyEventBus';
26

27
export default {
28
  name: 'amplify',
29
  components: {
30
    Authenticator,
31
    SignIn,
32
    SignUp,
33
    SignOut,
34
    ConfirmSignUp,
35
    ConfirmSignIn,
36
    ForgotPassword,
37
    SetMfa,
38
    Chatbot,
39
    PhotoPicker,
40
    S3Album,
41
    S3Image,
42
    SumerianScene,
43
    RequireNewPassword,
44
    Connect
45
  },
46
  AmplifyPlugin,
47
  AmplifyEventBus,
48
}
49
</script>
50

51
<style src='@aws-amplify/ui/dist/style.css'></style>
52
<style>
53
  .invalid {
54
    border-color: red;
55
  }
56
</style>

Read our documentation on viewing source code .

Loading